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Chapter 

1 
1 Overview 
1.  

Before setting up Perceptrak 4.0, it is important to understand the system and consider some 
pre-planning issues. It is also helpful to understand the various possibilities for configuration, 
depending on the layout of the facility and the number of cameras and operator stations. 

1.1 Understanding Perceptrak 
The demands on security departments and operators are growing at an ever-increasing rate. They 
monitor cameras, assign access badges, review video, and many other activities. 

This problem becomes more acute as more and more cameras are added to a CCTV system. It 
has been well established that the human eye and brain, while excelling at recognizing certain 
patterns and behaviors, becomes overloaded quickly. This is no reflection on the discipline or 
professionalism of the operator; it is simply human physiology, and it leads to the possibility of 
important events going unnoticed.  

In trying to remedy this, simply recording all video is inefficient, wasteful and expensive. Searching 
through recorded video for a particular event is tedious and difficult; by the very nature of recording, 
it can only be used as evidence after the fact. It can never help prevent a crime from happening. 

The Perceptrak System helps overcome these problem by relieving an operator of the tedium of 
monitoring cameras in low-traffic yet vitally-important areas, such as stairwells, parking garages, 
vaults, storage rooms, etc. Perceptrak works by analyzing the camera view, identifying and isolating 
the background, examining the remaining objects, identifying targets as People, Cars or Noise, and 
alerting the operator to what it has found, based on an easily programmed set of parameters. This 
also allows searching by specific behaviors, and filtering out unimportant events, drastically 
shortening the time required for reviewing video. 

For example, a stairwell may have little activity most of the time, but is still an obvious security, 
safety and liability risk. An operator cannot efficiently and continually monitor this type of area, but 
needs to be alerted immediately if an event occurs such as if a suspicious person spends too much 
time waiting there. Perceptrak can monitor this area continuously, ignoring normal pedestrian traffic, 
but alerting the operator within seconds of detecting a person lurking there beyond a predetermined 
time limit. Multiply this scenario times many cameras, or a single averted incident, and the value of 
Perceptrak becomes apparent.  
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Another example is a remote, unstaffed facility with little activity. It is unlikely that a guard will 
monitor video from such a facility. Nothing at all might happen for days, but if suspicious activity 
does occur, an operator can be notified immediately, the video recorded, and other functions 
performed, such as locking a gate or triggering lights and sirens. 

Perceptrak is the equivalent of having a dedicated guard monitoring each individual camera in a 
CCTV system. This guard does not sleep, take breaks, or step away to get a cup of coffee. 
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1.2 Perceptrak Software and Hardware Components 
Perceptrak is made up of six major software components and five hardware components. 

For software components, Perceptrak Arbitrator is the controlling application that launches 
Perceptrak, Video Analytics Engine, Review Station, Alert Monitor, and Call Up Monitor. PS 
Administrator configures Perceptrak, including cameras, IP addresses, profiles, and behaviors. The 
Review Station plays back recorded video, allowing live monitoring and remote control of Pan, Tilt, 
Zoom (PTZ) Cameras. Alert Monitor displays alert video clips for the operator. Lastly, Call Up 
Monitor displays live cameras for the operator. 

Perceptrak’s hardware components include the Master Console (MCON), OPCON, RVP16, the 
System Server (RSVR), and the Satellite Video Processor (SVP4). 

The figure below depicts a small Perceptrak system with up to 16 cameras. In this configuration, 
Arbitrator and Administrator both run on the MCON. Only event video is pushed out over a network 
to the MCON and shown on the Alert Monitor and Call Up Monitor. This system requires an IP 
address for the VPU and another for the Console. 

`

MCON
Alert Monitor

Call Up Monitor
Review Station

Arbitrator
PS Administrator

VPU
Video Processor Unit:

Video Analytics Engine

 

Figure 1.1: Small Perceptrak System with up to 16 cameras 
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Additional video processors may be added to increase capacity as seen in the figure below. The 
administrator should add a server for more than 48 cameras. Each component will require a unique 
IP address. All video recording and processing is done at the RVP16s. RVP16s are video analytics 
engines and only send alert video to the Consoles, thus preserving network bandwidth. 

 

Figure 1.2: Large Perceptrak System with 80 or more cameras 
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1.3 Pre-planning Considerations 
For maximum effectiveness of a Perceptrak System, involve the various staff and departments who 
will be either involved in the Perceptrak implementation, affected by it, or expect results from it. 

The IT Department should be apprised of the requirements of Perceptrak and how it might impact 
their physical infrastructure (cabling, equipment closet and rack space, sufficient monitors, cooling, 
etc.) and their virtual infrastructure (bandwidth, IP Addresses, remote access, etc.) 

Security Staff and Supervisors need to be interviewed. Questions to ask include: 

1. Are there areas they currently are not monitoring that should be considered?  
2. Do they use PTZ cameras?  
3. Do they have adequate monitors in their security office? 

 
Facilities Management needs to provide some input as well on things like site installation and 
placement of equipment.  They may also provide areas they would like monitored for specific 
behavior. 

Other questions should be asked, including: 

1. How many people will have access to the system? 
2. How long do you wish to store the video? 
3. Is there sufficient bandwidth at remote sites? 

 
This initial planning session should include anyone who may have a vested interest in Perceptrak. 
The session should include a thorough explanation of how Perceptrak works and what it realistically 
can do, so that all expectations are addressed. 

1.4 Network Considerations 
There are practical concerns regarding network configuration, bandwidth, access, and topology. 
Perceptrak operates optimally in a workgroup environment. It will operate in a domain environment, 
but more planning and support is required; default permissions and policies can interfere with 
communications between Perceptrak’s various modules and cause interruptions in monitoring.  

 

Note 
Contact Cernium Customer Support before implementing Perceptrak in a domain environment. 
Implementation in a domain environment is possible but not recommended at this time. 
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1.5 Site Considerations and Survey 
Once you have determined how Perceptrak will be used, perform a site survey. This is a physical 
walk-through of the site (or a representative sample) with the interested parties. The users’ 
expectations will drive choices in cameras, lenses, camera placement, and more. For instance, if 
you are concerned about trip and fall scenarios under icy conditions and you select Fallen Person 
as a Perceptrak-monitored behavior, the camera should have a reasonably wide, unobstructed field 
of view and be mounted low enough for a horizontal view of the monitored area. 

It is advisable to consult with Cernium’s Professional Services Group on specific behaviors and 
optimal camera selection and location. 

 

1.6 CCTV Considerations 
Camera age and quality is a major consideration, as well as position, location, and field of view. 
Some cameras, connectors, or cables may need to be serviced, replaced, or moved. 

 
A major consideration of the site survey is to identify any parts of an existing system that may 
require maintenance. If possible, each camera that is a candidate for Perceptrak should have its 
video output examined using Cernium’s Check Video tool. 
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1.7  Setting up Perceptrak 
Please follow the instructions below for setting up your Perceptrak system. 

1. Unpack and inventory the equipment 
 Check contents of the package against the packing list: computer, dongle, video input 

adapters, etc. 
 Inspect all components for damage that may have occurred during shipment. 
 Report any discrepancies as soon as possible. 

 
2. Install system 

 Rack/Deploy the machine in a suitable computing environment. (backup power, 
cooling, cable management, secured area, etc.) 

 Label and tag equipment according to local policy.  
 

 
3. Make external connections 

 Make all connections according to your installation plan, including keyboard, mouse, 
monitor, KVM switch, Ethernet, etc. 

 Connect video input adapters to capture cards and terminate incoming video feeds. 
 

 
4. Power up and test the system 

 Power up the system and look for any abnormal run-time errors.  
 Check for fan operation, unusual sounds, or any other indication of a 

system/component problem. 
 Report any problems as soon as possible.  

 
5. Follow the instructions for configuration provided in this chapter 

 Set all network parameters per installation plan, including IP addresses, Subnet 
mask, gateway, etc.  

 Continue with setup and configuration procedures outlined in the manual. 
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Chapter 

2 
2 Configuring Perceptrak 
2.  

The system administrator will need to log onto PS Administrator first and set up some basic system 
configurations. The basic outline of this configuration sequence is highlighted in Figure 2.4. 

First, you need to select a site for PS Administrator. A site is another name for a database; the 
factory default site resides under C:/PS_Data.  All programming settings will be stored at this 
location.  If a different Site is desired, click Site > Switch Site, then enter the name and file location 
of the alternate Site using standard Windows conventions. 

To log onto Perceptrak, double click on the PS Administrator icon. Click Login > Login. 

 

 

Figure 2.1: PS Administrator Login Dialog 
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Type in your User ID and Password. The default User ID and Password are both “user.” 

 

 

Figure 2.2: Login Dialog 

 

Note 
For first time logging in, enter User for both the User ID and Password. This is the factory default 
setting. Be sure to change the password after initial log in. 
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When you first power up the system, the configuration will be set to the factory test configuration. 
Project-specific data will have to be entered, and factory test data may be deleted. The suggested 
configuration sequence follows: 

 

Figure 2.3: Configuration Sequence 
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2.1 Assign Users and Roles 
From the PS Administrator Window, click Users > Manage Users. This will open the View Active 
Users Window. 

Click Users > Add to open the Add New User Window. 

 

 

Figure 2.4:  View Active Users

 
Enter the new user’s full name, employee ID number, email address, User ID, and assign an 
access level. 

Name:  This is a text field without leading spaces, periods, or special characters. 

Employee ID: This is a user-defined field; it must be unique. 

E-mail:  Enter a valid email address to receive notices. 

User ID:  This must be a unique user ID less than 10 characters (No spaces, punctuation, or 
special characters allowed.) This ID is used to log on to Perceptrak. 

Password: No spaces, punctuation or special characters allowed. The password must be at least 
five characters long. 
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Assign an appropriate access level for the user by entering the desired level: Administrator, 
Supervisor, Operator Level 2, or Operator Level 1,or select it from the drop-down list. (Administrator 
has full access privileges.) 

After entering and confirming the user’s password, click the Add button to close the Add New User 
Window.  Add additional users as needed.  

Changes to a user’s profile require the individual user to login and make them. Click Users > Edit 
to open the Add New User Window.   

 

 

Figure 2.5:  Edit Users

 

If a user forgets a password, the old user profile must be deleted out, then a new one added. Only 
an administrator can do this. 

 
Note 
Be sure to add a System Administrator, then delete out the Default User. Refer to the section on 
User Privileges for further information. 
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2.1.1 User Privilege Levels 

The following table shows the user privilege levels for administrators, supervisors, and operators. 

PS- Administrator Menu Access Administrator Supervisor Operator2 Operator1 

Login X X X X 

Configure Hardware X X   

Configure, Remote Stations X    

Cameras X X   

Cameras, Manage Cameras X X   

Cameras, Review Cameras X X   

Cameras, Tune Cameras X X   

Cameras, Groups, Camera Groups X X   

Cameras, Groups, Scoring Groups X X   

Cameras, Profiles X X   

Cameras, Profiles, Manage Profiles X X   

Cameras, Profiles, Review Profiles X    

Event Handler X X   

Event Handler, Define Inputs X    

Event Handler, Define Inputs, Manage Dry 
Contacts X    

Event Handler, Define Outputs X    

Event Handler, Define Outputs, Manage Dry 
Contacts X    

Event handler, Manage Events X    

Event Handler, Review Events X X   

Event Handler, Event Schedule X    

Event Handler, Behavior Messages X    

View Logs X X X  

View Logs, Event Log X X   

View Logs, System Log X X   

View Logs, Supervision Log X X X  
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Users X X X X 

Users, Manage Users X    

User, Edit Users X X X X 

Site X X   

Site, Switch Site X X   

Help X X X X 
 

Figure 2.6:  User Privilege Levels

 

 

2.2 Groups 
 

Groups and Profiles are based on your Perceptrak Site Survey, which outlines the architecture of 
your Perceptrak System.  Based on this document, several natural groupings can be defined. 

2.2.1 Camera Groups 

Camera Groups is a logical organization of cameras that are monitoring similar environments, such 
as stairways, parking lots, elevator lobbies, etc. By grouping like cameras together, the scoring 
process is simpler and more effective. There can be as many Camera Groups as needed. Groups 
are used to route cameras to particular Consoles. 

 

Figure 2.7: Camera Groups 
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2.2.2 Defining Camera Groups 

Camera Groups are a logical way of segmenting cameras for monitoring purposes. For example: 
Cameras viewing the elevators of building 1 could be assigned to a monitor group “Building 1 
Elevators” or “Elevators – BLD1.” 

Camera Groups are used to route cameras to a particular console for viewing; each camera must 
be assigned to a Camera Group. 

From PS Administrator, click Camera > Groups > Camera Groups to bring up the Manage 
Camera Groups Window. 

 

 

Figure 2.8: Camera Groups 

 

Add the Camera Groups by entering a unique Camera Group Name and Description for each 
Group. Click Add after each new group to add it to the list. If you need help with this, contact 
Cernium for an installation planning worksheet. 
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Figure 2.9: Manage Camera Groups 

 

Note 
Cameras must be assigned to Camera Groups, which are then assigned to Consoles for 
monitoring. 

Camera Groups containing cameras must be assigned to a Console or Consoles. OSR playback 
also filters recorded video by Camera Groups.  

2.2.3 Defining Camera Scoring Groups 

Typically, each camera does not need to be scored individually. Many cameras will have similar 
needs to record, detect and report similar events. Camera Scoring Groups configure the events to 
be reported, event values, time zones and recording functions. Cameras are then assigned to 
Scoring Groups. There can be as many Scoring Groups as required. Each Scoring Group may 
have one to 12 time zones. Each time zone may have different event values and activate or 
deactivate the recording function for that time zone. Perceptrak time zones must total 24 hours and 
start and stop at midnight. 

2.2.4 Scoring Group Concepts 

From the Perceptrak Administrator window, click Camera > Groups > Scoring Groups. The 
Manage Scoring Groups window will open. Score All is Perceptrak’s factory default camera 
scoring group, so it is not necessary to add a Camera Scoring Group initially. Cameras may be 
reconfigured at any time. 
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Scoring Groups is a logical organization of Behaviors based on desired reporting of different 
behaviors under different conditions, and perhaps at different times. Behaviors are selected based 
on previous discussions with the users on what type of behavior they wish to be alerted to, from 
each area being monitored.  

Scoring assigns a reporting value to each camera. Each level of priority adds a function in addition 
to the function of the lesser score. 

O Off: no alerts are generated, but camera is recording 

L List: sends to List box on Console; does not display camera 

S Show: displays alerted camera on Quad Viewing area of Console 

P Preempt: if Quad is full, preempts a camera to make room for highest priority alert 

Cameras can be assigned by group to a Scoring Group when similar alerts are desired. Also, 
Scoring Groups can be created to give different results based on time of day, holiday schedules, 
etc. 

 

Figure 2.10: Scoring Groups 
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Figure 2.11: Configure Scoring Groups 

 

Configure Scoring Groups allows a user to define a core set of Scoring Groups. These groups 
define which events will be recorded, at what alert levels, and can be broken down to 12 time zones 
per 24-hour period. 
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2.2.5 Events 

There are 18 pre-defined recordable Perceptrak events: 

Single Person: When any single person is detected in a camera view.  
Fast Person:  When a person moves at a rapid pace compared to average.  
Fallen Person: When a person that has been in the camera view changes aspect 
ratio from mainly vertical to mainly horizontal.   

 

Lurking Person: When a person is stationary in an area for a defined period of time.  
Erratic Person: When a person takes and indirect route through the camera view.  
Multiple People: When more than one person is detected in a camera view.  
Converging People: When two or more people approach each other in the camera 
view. 

 

Crowd Forming: When people form a crowd.  
Crowd Dispersing: When people disperse from a crowd.  
Single Vehicle: When any single vehicle is detected in a camera view.  
Fast Vehicle:  When a vehicle moves at high speed compared to average.  
Slow Vehicle: When a vehicle moves at slow speed compared to average.  
Sudden Stop : When a vehicle makes a sudden stop. 

 in a camera view Multiple Vehicles: When more than one vehicle is detected 
Stationary Object: When a new object enters the camera view and then remains  
motionless for a definable period or time. 

 iew is detected. Motion: When any motion in the camera v
 one to a defined secure Wrong Way: When a person moves from a defined public z

zone. 
 m Mode: When a defined object of interest is removed from a camera view.   

 
Museu
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2.2.6 Creating New Scoring Groups 

From the PS Administrator Window, click Camera > Groups > Scoring Groups. This will open the 
Manage Scoring Groups Window. To create a new Camera Scoring Group, enter a unique Camera 
Scoring Group name in the text box. 

 

 

Figure 2.12: Manage Scoring Groups 

 

Click the Add button to add the new scoring group to the list.  Double click on a scoring group and 
the Configure Scoring Group window will open. (A new group will only contain one time zone when 
created.) 

Note 
If a group is ghosted, there are cameras assigned to that group, and this group cannot be deleted 
until the cameras assigned to this group are re-assigned to a different group. 

2.2.7 Configuring New Time Zones 

From the Manage Scoring Groups Window, right click on a Scoring Group and click Configure. 
To create a new Time Zone, click Time Zone > Add. 
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Figure 2.13: Add Time Zone 

 

A new time zone tab will be enabled.  There are 12 possible time zones. After adding the desired 
number of time zones, you can set the exact Start and End time for each individual zone. Clicking 
on the arrows located adjacent to the Start and End time boxes does this. 

 

Figure 2.14: Start and End time 

 

To view the impact of the various time zones, click Time Zone > View to toggle the time zones 
window. 

 

Figure 2.15: Time Zones 

 

Time zones must total 24 hours and start and stop at midnight. 

2.2.8 Configuring Event Values 

After establishing the time zones for this scoring group, click each time zone tab to configure the 
active event. Each time zone may have different event values and activate or deactivate the 
recording function for that time zone. 
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1. To configure an Event Value in any time zone, you must first enable it in Time Zone 1. To enable 
an event, click the icon next to an event in Time Zone 1. The event will be highlighted all in blue 
when it is active.  

2. To configure subsequent Time Zones, select the time zone tab to move to the page for that time 
zone and move the slider adjacent to the event. Each event will report the score you indicate with 
the exception of the Quiet Boost event. This event, if enabled, will add its value to any event in that 
time zone only if the camera has been quiet for a minimum of five minutes. To enable Quiet Boost, 
check the box next to the desired behavior. 

 

Figure 2.16: Configure Scoring Group 
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2.3 Profiles 
 
Perceptrak uses Profiles to assemble specific behavior detection parameters in the most effective 
manner for various environments. The default is the Standard profile, but there are also profiles 
such as Indoor and Outdoor, as well as customized, user-defined profiles that can be created by an 
administrator. For instance, setting a stairwell Camera Group to the Indoor profile will prevent 
Perceptrak from attempting to identify Vehicles from that Group, making the system more efficient 
and lessening the chances of false positive alerts. 

 

2.3.1 Camera Profiles 

Camera Profiles help in the system configuration by allowing a camera profile association with 
multiple cameras as opposed to configuring each individual camera. Each camera must be 
associated with a camera profile. 

 

 

Figure 2.17: Review Camera Profiles 
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2.3.2 Creating and Managing Camera Profiles 

 

Camera profiles are used to modify event detection parameters.  Camera Profiles may alter several 
parameters and be applied to many cameras. Every camera must be assigned to a profile. 

Standard is Perceptrak’s factory default camera profile, so it is not necessary to add a camera 
profile initially. Cameras may be re-configured at any time. There are also seven additional profiles 
that can be imported. See section 2.3.3 below. 

 

Figure 2.18: Manage Profiles 

 

1. From PS Administrator, click Camera > Profiles > Manage Profiles to bring up the Manage 
Profiles window. 

2. To create a new camera profile, click File > New and enter a new profile name in the Profile 
window that appears. 

3. Click OK and the Choose Parameters Window will open.   

 

Note 
Most cameras fall into the factory supplied profiles. Manage Profiles is used only for exception 
cameras. 
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Figure 2.19: Choose Parameters 

 

4. Select the parameters you wish to use in this profile from the list on the left, and use the arrow 
keys between the two list boxes to either select all the parameters (- >>), select the highlighted 
parameter (- >), remove the highlighted parameter from the list on the right (< -) or remove all the 
parameters from the list on the right (<< -).  

5. Once you have selected the parameters you’d like to use in this profile, click the Next button. 
The Cancel button will close this window and discard the profile you started to create. 

6. After finishing with the Choose Parameters window, the Assign Values window will open. 
Clicking on an event value in the Value column will bring up an Update Value window for that 
parameter. Change the parameter value and select OK to save your changes. 

7. File > Save on the menu will save the changes to the profile. If you would like to create a new 
profile based on an existing one, open a profile, make any changes, and select File > Save As, 
entering the name of the new profile. 

8. To edit, add or remove parameters Highlight the profile then click Profile > Edit. 
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2.3.3 Importing and Exporting Camera Profiles 

PS Administrator allows Camera Scoring Groups to be imported and exported. From PS 
Administrator, click Camera > Profiles > Manage Profiles to bring up the Manage Profiles 
window. Click File and you will see the Import and Export options. There are eight profiles with 
every system. 

 

 

Figure 2.20: Manage Profiles, Import, Export 

 

Profiles are located on C:\ PS_Data\ Profiles. 

2.3.4 Reviewing Camera Profiles 

Camera Profiles is a configuration of camera settings that can be applied to one or more cameras. 
This profile feature aids in the system configuration by allowing a camera profile association with 
multiple cameras as opposed to configuring each individual camera. 

Clicking Camera > Profile > Review Profiles will allow you to review profiles without changing 
them. 

Standard is Perceptrak’s factory default camera profile. Others are Outdoor, Stairwell, Head Lights 
Glare, Interior Corridor, Medium Corridor, Moving Shadow, and Night Outdoor.  
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Figure 2.21: Review Profiles 

Note 
Review Profiles is a read-only window and does not allow changes. 
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2.4 Set Up Custom Messaging 
To customize the messages, under the PS Administrator menu, click Events > Behavior 
Messages. 

 

 

Figure 2.22: Behavior Messages 

To change the name of the message, left click on the line containing the Behavior and Message 
row you want to change. Type a replacement name in the Message field at the right. Click Update. 
The message name will then change to the new name. 
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2.5 Adding Cameras / Managing Cameras 
A Scoring Group, a Camera Group, and a Camera Profile will be required to fully configure a 
camera. 

1. From the PS Administrator Window, click Cameras > Manage Cameras to bring up the Manage 
Cameras Window.  

 

Figure 2:23: Manage Cameras 

 

The factory test configuration will appear. Lighter, ghosted icons indicate that the cameras are 
presently assigned to ports. Full color camera icons indicate that the cameras are not assigned to 
ports and may be deleted. You can change the sort order by clicking on the heading of the column 
that you want to sort. 
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Figure 2:24: Manage Cameras 

 

2. To add new cameras, enter the Camera Name, Camera Number and CCTV Switch Port in the 
appropriate text boxes. The standard is to assign camera numbers based on the corresponding 
CCTV Switch Port. 

3.  If the camera supports Pan Tilt Zoom, Color, or High-Resolution, enter that information now.  

4. Color-enabled cameras may be further configured. 

 

Figure 2:25: Color Enabled 

 

5. Users will be able to select high-resolution recording or standard resolution recording and 
analysis. 

 

Figure 2:26: High Res Enabled 
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Note 
Recording in color or high-resolution produces larger file sizes. 

 

6.  Click the Add button to add the camera to the list.  Once in the list, the camera icons will appear 
as Under Construction icons until other data is assigned. Repeat this process until all cameras are 
entered.  

 

 

2.5.1 Deleting / Editing Cameras 

1.  Click on the camera that you want to delete to select it. 

 

Figure 2:27: Delete Camera 

 

2.  Delete the selected camera by either clicking Camera List > Delete or by right clicking on the 
camera and selecting Delete from the drop-down menu, as depicted above. 

Note 
If the camera is assigned to either a port or a console, you will see a dialog box instructing you to 
unassign the camera before deleting it. To unassign a camera, right click on a camera in the 
Manage Hardware window and select unassign from the drop-down menu. 
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To configure a camera, double-click on a camera in the list. The Edit Window will open. Select a 
Scoring Group, Camera Group, and Camera Profile from the appropriate drop-down box in the Edit 
Window that appears. 

 

Figure 2:28: Edit Camera 

 

Click the Update button to save the data or the Cancel button to discard your changes. 

3.  Repeat until all cameras are configured with a Scoring Group, Camera Group, and Camera 
Profile. 

Note 
The Camera Under Construction icon will change to a ghosted Camera icon. The ghost camera 
icon indicates that the camera is now configured to groups. 

4.  To unassign a Camera from a Group, select Unassign from the drop-down list in the edit 
window. This action will unassign the group and cause the selected camera icon to change to the 
Under Construction style icon. 

5.  To change a Camera Scoring Group, Camera Group, or Camera Profile, select one from the 
corresponding drop-down lists in the edit window. 

6.  When satisfied that all Cameras are configured, close the window. 
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2.5.2 Configuring Pan, Tilt, Zoom Cameras 

From the PS Administrator window, click Cameras > Manage Cameras to bring up the Manage 
Cameras window. To configure the PTZ, highlight a camera in the list and check the box next to it. 
Click PTZ/IP Camera > Configure PTZ/IP Camera to bring up the Configure PTZ Window.  

Note 
PTZ must have been activated when the camera was added for Configure PTZ to be available. 
Also, the PTZ camera must be highlighted and checked before the PTZ can be configured. 

 

 

Figure 2:29: Configure PTZ 

 

Your documentation from the camera manufacturer will contain the Driver, Baud, Parity, Data, and 
Stop information. 

Select the serial communication port, which supports the RS-232 standard of communication. 

2.5.3 MPEG Settings 

If recording in MPEG, you can configure the settings by highlighting a camera in the list. Click 
Camera List > MPEG Settings to bring up the MPEG Settings Window. 
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Figure 2:30: MPEG Settings Menu 

 

 

Figure 2:31: Changing MPEG Settings 

 

Users may record 10 to 30fps using MPEG 4 ( frames per second). 

Users will be able to select high-resolution recording or standard resolution recording.  

2.6 Summary 
 

At this point, the system should recognize all components. Any of the components or component 
values can be edited, changed, expanded, or deleted. You may use this process to modify the 
current set up or initiate an entirely new security plan using configured components. 

The complete Tuning process consists of: 

 Combining the selected cameras into logical Camera Groups 
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 Assigning these groups to the appropriate Scoring Group 
 Performing preliminary Masking of each camera view 
 Assigning each camera to the appropriate Profile 
 Allowing the Perceptrak System to monitor cameras for an appropriate length of time 

(determined by the activity level of each camera) 
 Reviewing all cameras alerts in the Console List Box, taking notice of any False 

Alerts, and verifying that all cameras are reporting 
 Adjusting Masking, Scoring and Profiles as needed. 

 

 

Note 
Allow Perceptrak to operate long enough to allow all cameras to record under various conditions. 
Then, perform a final review of the tuning. 
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Chapter 

3 
3 Programming Events 
 

3.1 Events Overview 
 

This section of Perceptrak is used to manage the System Activity related to various system events. 
Here, specific input data (event trigger) from a variety of sources is received, such as dry contact 
inputs, video events, diagnostic events, or external software-generated inputs. Once the input is 
received, logic is applied to determine whether to generate an action. If the logic dictates action to 
be taken, the predefined set of events will be performed. These actions can be single or multiple 
events. 

Several parameters require setting up before an event can be created. First, user specific Event 
Schedules must be created. To do this, see the Creating Event Schedules section of this manual. 
Then, the basic component of events, inputs and outputs, must be configured.  

Note 
Cernium recommends having a list of all Dry Contacts before configuring events. 

3.1.1 Video Events 

Video Events are simply actionable (i.e. sent to console when scoring criteria is met, etc.) 
Perceptrak has over 25 video input events. 

3.1.2 Diagnostic Events 

Diagnostic Events are powerful features, which alert a user to hardware malfunctions.  Video 
Processor failure and camera failure are examples of diagnostic events. 

3.1.3 Time-Generated Events 

An event may be triggered by the time of day. For instance, the system may be set to initiate certain 
PTZ Camera to go to preset locations and start monitoring the video with Perceptrak analysis.  
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3.1.4 User Override  

A user override is a capability that is required to temporarily suppress the event. Perceptrak 
includes an Operator Console menu selection for this purpose labeled Suppress Event. 

 

3.2 Event Logic 
When an event has been triggered, additional logic is applied to determine whether to take action or 
ignore the event. Each event can have a specific name assigned to it by the administrator at time of 
programming if desired. The logic components are as follows: 

3.2.1 Enabling Time  

Events are enabled using enabling times similar to those currently on Perceptrak. If there is no 
enabling time selected, the system will not take action. 

3.2.2 Linking Inputs 

Two or more inputs may be linked to enable an action. For instance, on a given event, the system 
may be programmed to take action only when two inputs occur within a given time frame. Example: 
Contact Input + Analysis (person) = action. 

3.2.3 Priority 

Each Event is given a simple low, medium, or high priority. A higher priority Event will supersede a 
lower, etc. Events of same priority are serviced as they are on Perceptrak on a first-come, first-
served basis. 

3.3 Event Action 
After event logic has been applied, the resulting action can be various user programmable functions 
that show up on the User Console. The actions are described as follows: 

3.3.1 Video Display 

Video display refers to the ability to switch video up to the console Window based on an event. This 
is the same as is done now with the Perceptrak system. The event log would reflect the type of 
event that triggered the event. 

3.3.2 Event List 

The Event List is a rolling log of event activity. 
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3.3.3 User Acknowledge 

Many facility operations require events to be acknowledged by the security staff. The User 
Acknowledge list of events will reflect whether a specific event has been acknowledged.  

3.3.4 Audio Alert 

Audio Alert enables a specific tone when a type of event occurs. 

3.3.5 Pager/SMS  

Pre-programmed Paging or SMS messaging is available to alert security personnel of specific 
events. 

3.3.6 Email  

An email can be generated to alert security personnel of specific events. This is very useful, 
especially for diagnostic events. 

3.3.7 Contact Output 

A simple dry contact output can be used to activate other functions such as turning on lights, etc. 
This may be held on until reset or pulsed at preset duration. 

 

3.4 Defining Contact Inputs 
Contact inputs are dry contacts, which are physically connected to a switch or switched output from 
a device such as a door contact, PIR, etc. Dry contacts are able to identify a point as normally open 
or normally closed for status. Dry contact sensors are user definable and can be used to detect 
many different inputs.   

 

Figure 3.1:  Defining Contact Inputs
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1. In the PS Administrator, go to Events > Define Inputs > Manage Dry Contacts. This will bring 
up the Input Dry Contacts Window. 

2. Enter a unique contact name in the Contact Name text box. The name entered will be mirrored in 
the Message text box. It is recommended that the contact name include a short description of what 
happens where. For example, if the first dry contact configured is of a door opening in stairwell A, 
an appropriate name might be “Door Open Stairwell A.” The message field is what will be sent to 
the output selected, so an accompanying message might be “Door Open Stairwell A Activated.”  

 

 

Figure 3:2 Input Dry Contacts

 

3. Enter a Latch Seconds period of time. The Latch Seconds time ensures that if a switch is closed 
for less than one second, the system will still detect that the switch did close, and will report it to the 
appropriate source. It is recommended that the contact be configured with a Latch Seconds time of 
1 or 2 for highest effectiveness.  

4. Select the Video Processor where the dry contact is physically connected.  Perceptrak supports 
eight dry input contacts per Video Processor. 

5. Select the contact number. 

Dry Contacts are assumed to be inputs that are usually closed, and will invert this logic if the 
Normally Closed checkbox is checked. 
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3.5 Defining Outputs 
Note 
Corresponding Input and Output numbers do not associate contacts with each other. Contacts are 
not associated with each other until they are specified to be associated in the Manage Events tool. 

There are currently four output categories: Manage Dry Contacts, E-Mail, Pager/SMS and 
Message to List. 

3.5.1 Output Dry Contacts 

The Dry Contacts output is similar to the Dry Contact Input. The major difference being Latch 
Seconds used in an output Window signifies the amount of time the contact stays latched. 

1. In the PS Administrator, go to Events > Define Outputs > Manage Dry Contacts.  

2. Enter a unique contact name into the Contact Name text box. The name entered will be mirrored 
in the Message text box. Cernium recommends that the contact name include a short description of 
what happens. For example, if the first dry contact configured is of lights flickering, an appropriate 
name might be Lights Flicker. The message field is what will be sent to the Exceptions log, so an 
accompanying message might be Lights Flicker Activated. (Note that this is simply the name of a 
type of dry contact output. You will not have to configure more than one of each type of the dry 
contact outputs.) 

3. Enter a Latch Seconds period of time. The Latch Seconds for Output Dry Contacts configures 
the amount of time for which the output will actually “fire.” For example, if the output were flashing 
lights, the time that the lights would flash would be the number of Latch Seconds.  

4. Select the appropriate video processor that the dry contact will be connected to. Perceptrak 
supports eight dry output contacts per video processor.  

5. Select the contact number.  

6. Click Add. Repeat these steps until all your system’s Dry Contact Outputs have been added. 
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3.5.2 Email 

Another available output is email.  If you would like to have the option of having an event emailed to 
a party, go to Events > Define Outputs > Email. This will bring up the Manage Email Window.   

 

 

Figure 3.3:  Manage E-mail

To set up a new email address to send the event to, right click and choose New or go to Email > 
New. The Configure Email Window will open.  
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Figure 3.4:  Configure E-mail

In the Configure Email Window, enter the person’s name, email address, subject, and message 
into the appropriate fields. If you would like a snapshot taken at the time the event was triggered, 
check the Attach Snapshot Checkbox.  

Note 
Perceptrak will include the Event Message when sending the email. A suggested message would 
be something like “This event requires your attention.” 

Administrator Manual  Chapter 3 – Programming Events • 42 



P E R C E P T R A K  4 . 0  

To configure the mail server, from the Manage Email Window, click Email > Configure Mail 
Server. 

 

 

Figure 3.5:  Email Server 

 

Enter the Server Name and your User Name and Password. Click Update. 
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3.5.3 Pager/SMS 

This option allows users to be alerted by pager or text message. The currently supported providers 
are Verizon, AT&T, and NEXTEL.  

1. To alert someone of an event via a pager or text message on a cellular phone (SMS), go to 
Events > Define Outputs > Pager/SMS.  

2. Right-click and choose New or go to Email > New. Enter the person’s name in the name field 
and the full ten-digit phone number without spaces or hyphens into the Address field, and a 
message into the message field.  

Note 
Perceptrak will include the Event Message when sending the text message. A suggested message 
would be something like “This event requires your attention.” 

3.6 Logic of Programming Events 
This option allows users to be alerted by pager or text message. The currently supported providers 
are Verizon, AT&T, and NEXTEL.  

1. To alert someone of an event via a pager or text message on a cellular phone (SMS), go to 
Events >Define Outputs > Pager/SMS.  

2. Right-click and choose New or go to Email > New. Enter the person’s name in the name field 
and the full ten-digit phone number without spaces or hyphens into the Address field, and a 
message into the message field.  

3.6.1 And Logic 

An Example of “And” Logic would be when there is a door with a “switch” to indicate when the door 
has been opened that has been programmed as dry contact Door Open. 

Along with knowing when the door has opened, you also want to know that there is a person who is 
standing near the door or entering the door. To configure an event that would tell you that the door 
has opened and a person is there, you would drag the dry contact Door Open and the behavior 
Single Person to the “Inputs to be AND-ed” text box. The event would now only be triggered by the 
occurrence of both these inputs within a configurable amount of time. 

Thus, the “Inputs to be AND-ed” allows you to combine any number of inputs to make events very 
selective. 
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3.6.2 Or Logic 

The same door that has a dry contact Door Open is near a sensitive area of your business. While 
you definitely want to know that the door is opened, you do not want to wait for the door to be 
opened to necessarily know that there is a person approaching the door. To configure an event that 
allows you to know either when the door has opened or a person has been detected, you would 
drag the dry contact Door Open to the “Inputs to be OR-ed” box, and the behavior Single Person to 
the “Inputs to be OR-ed” box. The event would now be triggered by either one of these inputs 
occurring within a configurable amount of time. 

3.7 System Events 
With the choices below, along with the dry contacts that have already been configured and 
connected APIs, a user can program any number of permutations for events.  

3.7.1 Behaviors 

Cameras must be selected for behaviors to be analyzed. The following behaviors can be 
programmed to signal events for analysis: 

 Single Person – a single person 
 Erratic Person – a person moving in an erratic fashion 
 Lurking Person – a person lurking in view of the camera for a period 
 Fast Person – a person moving quickly or running 
 Fallen Person – a person in the prone position or on the ground 
 Multiple People – multiple people 
 Converging People – people coming together to one area 
 Single Car – a single car 
 Multiple Cars – multiple cars 
 Fast Car – a car speeding or moving quickly 
 Slow Car – a car moving slowly 
 Sudden Stop Car – a car stopping suddenly 
 n view of the camera and Stationary Object – any stationary object that comes withi

remains 
 ion of motion at all 

The following Diagnostic Event Inputs would count as exceptions and could cause an interruption: 

Any Motion – any detect
 

3.7.2 Exceptions 
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 Bad Video  
 Failed to Start  
 Restart Failed 
 Disk Full 
 Information 
 Return to Normal 
 Lost Video 
 Offline 
 Hardware Lock Missing 

 

3.7.3 Creating a New Event 

To create an event, go to Events > Manage Events.   

 
 

Figure 3.6:  Manage Events
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Right click on the chart, and choose New, or go to Events > New. This will bring up the Choose 
Event Inputs Window. Expand all of the trees in the Available Event Inputs field. Here, you will 
configure dry contact inputs, Perceptrak behavior events, or system exceptions you would like an 
event to be triggered by. For example, if you want an event triggered by the motion of a single 
person on camera, you would click the Single Person behavior, drag it to one of the Inputs fields, 
and assign a camera to it. Then, click Next. 

Note 
Each behavior input must be associated with a camera, in order for it to work properly. Be sure to 
have your camera list available so you know that you are configuring the correct behavior with the 
correct camera. 

This will bring you to the Choose Event Outputs Window. Here is where you choose what actions 
(called outputs) you want taken when a certain input occurs. Expand all of the trees in the Available 
Event Inputs field. For example, if you want a message to be sent to the Perceptrak Console when 
a Door Open input is detected, you click Console output, and drag it to the Outputs field. Click 
Next.  

The Configure Event Window is where you will name and finalize the event. Enter a unique name 
into the Event Name field, which will describe what actions have taken place at the input.  

 

Figure 3.7:  Configure Event

 

The “Use Message of…” field will enable you to choose what message will be logged in the 
Exceptions log or sent to the output. If you choose the “First True Input” selection, the first input that 
is activated will send the message that was set up for that input to the output. Choosing “Configured 
Event” allows the user to create an event-unique message that will be sent to the output. Choosing 
“Configured Output” will send the message set up for the specific output to the output.   

Note 
If there is only one input configured to the event, select First True Input for the message choice. 
This assures that the specific input, along with any camera information is included in the message. 

The Default Camera value comes up with Default selected, meaning it will make the event 
universal on the system. If the event should only be associated with a particular camera, scroll 
through the drop-down menu and select the camera it should be associated with.  
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Select an Event Schedule. This will configure when this event should be detected. In order to 
ensure your events occur on at the times you want them to, check Event Schedule. 

The Valid Time Span field is used specifically when two or more inputs are linked. “Valid Time 
Span” indicates the amount of time that is allowed to pass between the “firing” of two inputs for it to 
still count as an event. For example, if Door Open fired, and three seconds later, Single Person was 
detected; this would only be created as an event if the “Valid Time Span” were set at 3 seconds or 
higher. The default value for only one input should be set at 1 second.  

The Operator radio buttons are a last check to make sure the inputs are configured with the logic 
that you intend.  

The Event Priority choices specify what priority events will have when they encounter the 
processor. This does not affect the priority that the event has in the Console or Event List; it only 
would affect the order the processor “grabs” the event if there were a long list of events happening 
at once. Generally, the processor will “grab” events in the order they occur. Selecting a higher 
priority would ensure that the event would be seen quickly by the processor, and an output would 
be sent sooner for this event than it would normally be if it was handled in the order it occurred.  

Click Finish, and the event is created and listed in the Manage Events table.  

 

3.7.4 Scheduling Events 

Events are associated with an Event Schedule. An Event Schedule is similar to the Time Zones set 
up earlier.  There are 12 possible time zones. Events can be Enabled or Disabled for each time 
zone within a named event schedule. 

 

 
 

Figure 3.8:  Schedule Events

 

3.8 Using the System Hardware Tree  
From the PS Administrator window, click Configure > Hardware. The Manage Hardware window 
will open, showing a graphical representation, or “tree,” of the system hardware configuration on the 
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left side of the window. This configuration will serve as a template as you build, modify, or expand 
your system. 

 

 

Figure 3.9: Manage Hardware Window 
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To change the system configuration for this project, drag and drop the required hardware 
components from the Icon Bar to the tree.  

 

 

Video Processing Unit 

IP Camera 

Monitor 

Router (Video Switcher) 

Digitizer 

Console 

Figure 3.10: Icon Bar Containing Hardware Components 

Clicking on different tree components will reveal different information about the component at the 
right of the window. The IP address and online status will be displayed for all software components. 
Serial port configuration will also be displayed for the router module.  

To delete any component from the configuration, right click on it and select Delete from the drop-
down menu. You will have to work from bottom to top on the tree to delete some components if 
system resources are assigned to the device. A text box will appear with information if you are 
unable to delete an item. The message box in the bottom of the window will inform you of the status 
of changes to the tree.  

Note 
Do not check the External Connection box unless instructed to by Cernium. This is for use on 
customized applications. 

 

3.8.1 Configuring the IP Address  

When the IP Address box appears in the Manage Hardware window, that component requires an 
IP Address. Enter an address in the box, observing the following considerations: 

 

Figure 3.11: Configure IP Addresses Dialog 
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The IP Address used for each software component must correspond to the IP address that has 
been assigned to the computer hosting that component. For example, if Arbitrator, Console, and 
Call up Monitor are all on a computer with the IP Address 100.100.100.101, then this address 
should be entered for all three of those software components. 

In order for the Perceptrak software to communicate across a network, static (unchanging) IP 
addresses must be used. These addresses must all be in the same range and use the same sub-
net. For more information on configuring your computer’s IP address, see your network 
administrator. 

 

3.8.2 Configuring the Console 

To configure a console, right-click a Console symbol on the tree and select Configure from the 
menu that appears. This will open the Configure Perceptrak Console Window. 

 

Figure 3.12: Configure Console Window 

 

The factory test configuration data will be displayed. This data must be changed to project-specific 
data.  

List Score — Minimum score. Events at this score or higher will be recorded in the message list 
and then in the event log. 
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Show Score — Events scoring higher than this score will be sent to a console for display.  

Preempt Score — Events at this score will preempt the events being viewed on the console at the 
present time.  

Location — Enter a description of the location where the Perceptrak Console is installed. 

Monitor Ports — Do not change the default setting to this unless you are using an Analog 
Console. When using an Analog Console only, you may enter the CCTV system switch port 
numbers to feed the Perceptrak Console Quad Display.  

Call Up Port — Enter the CCTV system switch port number to feed the CCTV monitor used as the 
Perceptrak Console Call up Monitor  

For now, accept the default Preempt Score, Show Score, List Score, Max Dwell, Min Dwell, 
Operator Dwell, Upper Operator Range and Lower Operator Range values.  

 

3.8.3 Analog Versus Digital Consoles 

Assigning  default cameras to the Alert Monitor Console is primarily related to Perceptrak’s legacy 
support of analog switcher-based CCTV systems. The original design concept and implementation 
of Perceptrak was centered around this type of environment and provided the basis for the next 
generation of a network-based Alert Monitor Console. Depending on which implementation of the 
Alert Monitor Console is being used will determine what this configuration item will mean in terms of 
options and system functionality. 

The two implementations of the Alert Monitor Console described above are commonly referred to 
as: 

 Analog Console 
 Digital Console (Object Selected Streaming) 

 
The Digital Console is the standard, default configuration that is currently being shipped. The 
Analog Console is only for legacy systems. 
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A N A L O G  C O N S O L E  

When you implement an Analog Console, the default camera will determine what video will be 
present in each cell of the Quad display when the Console is not currently servicing any alarms. 
The default camera in this case can be either a blank display or an actual feed from a camera.  

For a blank display, you will use a dummy camera that is mapped to an unused video input on the 
matrix switcher. For example, if you have a 128 input switcher but are only using 100 of the inputs, 
simply allocate input 128 as your default camera. Depending on the switcher model and 
configuration, this will provide a blue/black background and any on-screen display that the switcher 
has enabled (date/time, camera number…etc). If the switcher is full, you will need to assign a real 
camera. If desired, a separate camera may be selected for each cell of the Quad. 

 

 

Figure 3.13: Analog Console 
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D I G I T A L  C O N S O L E  

When you implement a Digital Console, the default camera has no impact on the functionality of the 
Console; however, the assignment of a default camera is still required. The Cernium logo will 
always be the default view when the Console is not actively displaying video.  In this case, you will 
assign a dummy camera that is numbered above and beyond the actual number of cameras 
attached to the system. Current practice is to define a camera numbered C999 and use this as the 
default assignment for each Quad cell.  

 

 

Figure 3.14: Digital Console 

 

3.8.4 Assigning Default Cameras to Console 

 
Display default cameras will display in the Quad display on the Console when there is no activity. If 
you leave the default cameras unassigned, the Cernium logo will appear in each unassigned 
segment. This may be the preferred setup for your environment, as it draws attention to the 
cameras that Perceptrak assigns to the display. 

If you prefer not to see images on the quad display, leave the appropriate camera unassigned. If a 
camera is assigned to one of the four segments, right click on that camera and select Remove 
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from the drop-down menu. Repeat this for each segment of the quad display you would like to 
remain blank. 

To assign or change default camera views, double click on a camera or unassigned position to 
bring up the Add Camera Window. The Add Camera Window can also be viewed by clicking 
Cameras > Add from the menu.  

 

Figure 3.15: Add Camera Window 

 

Initially, the factory default cameras will be the only ones in the camera list that appears. When 
other cameras are configured, the list will automatically update to reflect the changes. Select a 
camera from the list and click Add to confirm your selection. Repeat until each camera icon has 
been replaced with the camera icon you would like in each quad sector. 

3.8.5 Assigning Camera Groups to Console 

From the PS Administrator window, click Configure > Hardware. Right click on the Console you 
want to configure.  Select Configure from the drop-down menu. From the Configure Console 
Window, click Camera Groups > Add. The Add Group window will open, with only the factory 
default Camera Groups included in the Camera Group list. When other Camera Groups are 
configured, the list will automatically update. 
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Figure 3.16: Add Group Window 

 

To assign a Camera Group to the Perceptrak Console, select a Camera Group icon from the Group 
list, and click Add to confirm your selection. Repeat until all desired Camera Groups are assigned 
to the Console. 

To un-assign a Camera Group, right click on it and select Remove from the drop-down menu.  

 

3.8.6 Managing Video 

Each Video Processor can be configured with various video recording and storage settings. To 
access the Video Management Window, right click on a Video Processor (Configure > Hardware 
in the hardware tree) and choose Management.   

 

Figure 3.17: Managing Video 
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Storage locations can be user defined (default  D:\ OSR). The OSR Path designates the base path 
where the video files will be stored. 

On every Video Processor, there is a percentage of the available storage for OSR storage and a 
percentage of storage designated to other processes. The operating system is considered one of 
these other processes. Within minimum limits, the ratio can be set with the slider  

Percentage OSR Storage. This percentage will be used to configure the File Management 
settings.  When you are finished dragging the slider, the pie chart will be updated to reflect the new 
settings. A minimum of ten percent disk space will be reserved for the operating system. 

 

Figure 3.18: Video Management 

With digital recorders, there is a tradeoff between recorded video quality and video storage 
efficiency. Increasing the image quality will lower the storage efficiency. Statistics for this are shown 
in the Video Management Window. You will have to determine these settings after you gain some 
experience with the recorded video quality and storage space required for the recorded video. 

When the Video Quality slider control is set too high, there is very little compression to any object 
in the video, which creates large files. When set too low, all objects in the video are heavily 
compressed, reducing file size significantly. A setting of five would lightly compress people, 
moderately compress vehicles, and heavily compress the background. This would dictate moderate 
file sizes and provide acceptable video. Cernium recommends a video quality setting of 5 to 8 for 
most applications. 

Cameras on this processor represent the distinct number of cameras that have OSR files 
residing on this processor. These cameras may or may not be active at this moment in time.  
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The Oldest Camera in Days is a close approximate of the age of the oldest OSR file on this 
processor. The File Management Process, using the percentage of disk space allocated to OSR 
storage, prunes the oldest files.  

If you make a mistake and want to discard your changes and return to the previous values, select 
File > Revert to return to the previously saved settings. Selecting File > Save will save your 
settings. Closing the Video Management Window will also prompt you to save settings. 
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Chapter 

4 
4 Logs 
Logs are important because they help the user keep track of significant events, administrative 
issues that may need to be addressed, and system and operational events that are noteworthy. 
Event Logs, Supervision Logs, and System Logs are all important tools in managing your 
Perceptrak system. These logs can help you do everything from retrieving lost video to identifying 
systems that have gone offline. 

 

4.1 Event Log 
 

To view the event log, click View Logs > Event Log from the Perceptrak Administrator window and 
the Event Log window will appear. The Event Log contains information on all the event detection 
and event transaction records from the entire system.  

The log has several sorting options. Date is the default option and presents all event data in 
chronological order. Clicking Sort > Camera Number will present the chronological events 
separated by Camera Number in Camera Number order. Clicking Sort > Console Name will 
present the chronological events separated by Console Name in Console Name order. 

Navigation buttons are provided to move through records one row at a time or jump to the 
beginning or end of the record set. The arrow keys may be used for navigation once an item on the 
list has been highlighted. The columns may be resized as necessary to read the complete 
message. Horizontal and vertical scroll bars are provided to help with the review when the list is 
larger than the window.  
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A Filter menu allows you to reduce the number of records to a particular category of message. The 
default filter setting is disabled (All), and you can click Filter > Message Received as appropriate. 
Selecting a filter category will limit the displayed records to that type.  

 

 

Figure 4.1:  Event Log

 

 

4.2 Supervision Log 
To view the supervision log, click View Logs > Supervision Log from the Perceptrak Administrator 
window and the Supervision Log window will appear. You will need to use the scroll bar at the 
bottom of the window to view the last column on the right. The Supervision Log contains all the 
information on detectable system errors or exceptions to proper operations. Some errors or 
exceptions are not detectable and consequently cannot be logged. Errors or exceptions are 
referred to as supervision events.  

Supervision events could affect the system performance and should be acknowledged by an 
operator and eventually cleared by a supervisor. To acknowledge or clear a supervision event, 
move the pointer to the desired supervision event and click the Acknowledge or Clear button. 
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Some supervision events are self-clearing; other supervision events may report problems that 
require repairs before they can be cleared.  

Sort options are selected by clicking Sort > Time Stamp, Sort > Acknowledged Time and Sort > 
Cleared Time. The Time Stamp (default) option displays all events in chronological order. 
Acknowledged time button will sort all acknowledged supervision events by the time the event was 
acknowledged. Cleared Time sorts all cleared supervision events by the time the event was 
cleared. Operators may acknowledge or clear supervision events from the Perceptrak Console.   

Navigation buttons are provided to move through records one row at a time or jump to the 
beginning or end of the record set. The arrow keys may be used for navigation once an item on the 
list has been highlighted. The columns may be resized as necessary to read the complete 
message. Horizontal and vertical scroll bars are provided to help with the review when the list is 
larger than the window.  

 

 
 

Figure 4.2: Supervision Log
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4.3 System Log 
To view the system log, click View Logs > System Log from the Perceptrak Administrator window 
and the System Log window will appear.  The System Log contains information on various system 
events including system startup, shut down, aged cameras, and. other operational events. This log 
is for informational purposes only and does not require that events be acknowledged or cleared. 

A Filter menu allows you to reduce the number of records to a particular category of message. The 
default filter setting is disabled (All), and you can click Filter > Manual Call Up or Filter > Normal 
Show as appropriate. Selecting a filter category will limit the displayed records to that type.  

 Sort options are selected by clicking Sort > Date (the default), Sort > Camera Number and Sort > 
Camera Name. 
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Navigation buttons are provided to move through records one row at a time or jump to the 
beginning or end of the record set. The arrow keys may be used for navigation once an item on the 
list has been highlighted. The columns may be resized as necessary to read the complete 
message. Horizontal and vertical scroll bars are provided to help with the review when the list is 
larger than the window.  

 

Figure 4.3: System Log
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Chapter 

5 
5 Tuning 
 

Tuning is the term used by Cernium to describe the overall process of grouping and configuring 
cameras in a logical, efficient manner, and adjusting the properties for each camera or group for 
maximum reporting accuracy. It also encompasses Scoring, which prioritizes the alerts to the 
Console(s). 

Tuning generally involves creating an starting configuration and observing  the alerts the system will 
begin sending to the Console. Each camera view must be examined for any needed masking, and 
Check Video should be run again to determine the video quality score as compared to the Pre-
installation Site Survey score. (A Check Video score of 50 or higher is required for best results). 

After allowing enough time to gather a representative sample of alerts from each camera in the 
Console’s Message Box, further tuning may be required for greater accuracy and to lessen the 
false positives.   

It is also important make note of any cameras that are not generating alerts, as these cameras may 
require further attention. Every camera should be verified for proper alert notification. 

Tuning may also indicate the need to alter the field-of-view or angle-of-view for a given camera to 
increase its reporting accuracy. Tuning may also require further masking to block out reflections 
that may decrease Perceptrak’s reporting accuracy.  

 

5.1 Check Video for Contrast/Brightness 
To Check Video, log onto PS Administrator. Click Camera > Tune Cameras > Camera 
Configuration. The Configure Cameras Window appears. Click Camera List > Check Video. In 
the Check Video Window, you can set the contrast and brightness of each camera. 

 

5.2 Masking 
Masking is a way for the user to define specific areas of a camera’s view for different purposes. For 
example, you can designate one area of the camera’s view for reporting significant events, another 
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area for securing, and another area that is a public area for everyday traffic that does not need to 
be monitored. 

 

5.2.1 Reporting Zone 

The Reporting Zone is the region you will mark for reporting significant events. By default, the entire 
area is selected for reporting and everything is reported. 

 

Figure 5.1: Managing Masks 

Use the Draw Mode tool to mark the Reporting Zone, Public Zone, and Secure Zone. Do not color 
in areas that you do not want to watch, like the rope swinging from the flag pole in the wind or the 
traffic in the street. Save Mask when you are finished. 
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Glossary of Terms 
 

Term Definition 
Alert Monitor This screen displays the video audio alerts in a quad format.  It also contains 

the Instant replay Monitor and Recent Activity List.
Audible on 
Camera 
Preempt 

An audible output that sounds a distinct audible alert when an event is 
posted to the list with a score equal to or above the Preempt threshold.

Audible on 
Exception 

An audible output that sounds a distinct audible alert when a supervision 
message is posted in the list. 

Audible on 
Message 
Receipt 

An audible output that sounds a distinct audible alert when an event is 
posted to the list with a score under the Show threshold.

Audible on 
Show Camera 

An audible output that sounds a distinct audible alert when an event is 
posted to the list with a score equal to or above the Show threshold.

Audible 
Outputs 

These are any audible tones or alarms configured to occur for various 
events. (See: Audible on Message, Receipt Audible on Show Camera, 
Audible on Camera Preempt, Audible on Exception.) Any of these items 
produce a distinct audible alert for each event of the type through the 
Console’s external speakers.

Call up Monitor The second component of the Operator Console. This is the window used to 
call up and view live cameras as well as PTZ control. 

Camera 
Groups 

A logical grouping of similar cameras in a specific area or location. For 
example, all cameras on level one of a parking garage or all cameras at a 
main entry. Camera Groups are used to route cameras to a particular 
console for viewing. 

Camera 
Profiles 

A configuration of camera settings that can be applied to one or more 
cameras. This profile feature aids in the system configuration by allowing a 
camera profile association with individual cameras as opposed to having to 
configure each camera separately.  Every camera must be assigned to a 
profile. 

Dwell time This is the amount of time a video image remains on the quad display. 
False Positive Perceptrak recognizes an object in the camera view, but misidentifies it. In 

certain circumstances, Perceptrak can also report an object/behavior that 
does not exist. 

Highlighted When the pointer is moved over certain items, they become bigger, more 
pronounced, or the background color may change to draw attention to that 
item.  This informs the operator that the item may be selected by clicking on 
it. 

High-
Resolution 

High Resolution is recording in 640 X 480 pixels. 

Instant Replay A short video loop starting before the event and ending after the event will 
play.  The duration of the video loop is configurable. 
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Term Definition 
Instant Replay 
Monitor 

This is the image screen positioned to the right of the quad display.  This is 
the window in which Instant replay can be viewed. 

List One of the three classifications of events. Sends to List box on Console; 
does not display camera. 

Low-Resolution Low Resolution is recording in 320 X 240 pixels. 
Menu A list of selections that appears on the computer screen.  Moving the pointer 

over one of these selections and clicking the mouse accepts that selection 
and performs that task.  Menu selections are generally highlighted when the 
pointer is moved over them to indicate that they are available for use. 

Masking Covering up specific areas of a camera view to eliminate false reporting, i.e. 
Windows. Masking in Perceptrak also includes defining areas of a camera view 
for various purposes such as where reporting should occur. 

Message-only One of the three classifications of events.  The priorities of these events are 
so low that they will simply go to the Recent Activity List with a message 
describing what they were.

Not 
Acknowledged 

Shows only entries that have not been acknowledged.  This option can be 
set to control the displayed records. (See Filter)

Not Cleared Shows only entries that have not been cleared.  This option can be set to 
control the displayed records.  (See Filter)

Object 
Selective 
Recording 

OSR is an advanced method for increasing the effectiveness of digital 
recording.  OSR indexes specific behaviors or events, which allows for quick 
and easy video recall of these events while reducing storage requirements. 

OSR Object Selective Recording 
Pre-defined 
Events 

Single Person, Multiple Persons, Fast Moving Person, Lurking Person, 
Erratic Person, Fallen Person, Converging People, Single Person, Multiple 
Persons, Fast Moving Person, Single Car, Multiple Vehicles, Fast Car, Slow 
Moving Car, Sudden Stop Car, Stationary Object, Motion 

Pre-empt One of the three classifications of events. These are events of the highest 
priority.  If all the quad screens are being used to play events, the pre-empt 
event will take the place of the oldest event playing, even if the display dwell 
time has not been fulfilled. 

PTZ Pan, Tilt, and Zoom 
Quad Four video screens where video of interest can be viewed.  This display will 

show a camera view in each of the four different quadrants when detected 
behavior activity with a high score occurs. 

Quiet Boost 
event 

This event, if enabled, will add its value to any event in that time zone only if 
the camera has been quiet for a minimum of five minutes. To disable Quiet 
Boost, set the value to zero.  

Recent Activity 
List 

A list of the last one hundred messages since the Console application was 
started.  It will add the most recent event to the top of the activity report list 
while dropping the oldest item from the list.  Messages in the Recent Activity 
List each contain the date, the time that the Event was posted, the camera 
ID, the numerical event score (higher is more important), and a descriptive 
message about the Event. 
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Term Definition 
Scoring group This is used to group cameras who have similar recording needs, and that 

will detect and report similar events.  Scoring groups configure the events to 
be reported, event values, time zones and recording functions. 

Show All Shows all entries in the log.  This option can be set to control the displayed 
records.

Show  One of the three classifications of events. Sends message to List and 
streams video to Quad.

Standard 
Resolution 

(See Low-Resolution) This is an industry standard recording resolution 320 x 
240. 

Status Icon Located on the left hand side of the event list, gives the user an indication of 
where an event is being displayed, if the event has been acknowledged, and 
if the event is a pre-empt priority. 

Supervision 
Log 

A log that contains all the information on detectable system errors or 
exceptions to proper operations.  Errors or exceptions are referred to as 
supervision events. 

Time Zones There are 12 possible time zones.  To view the impact of the various time 
zones, click Time Zone > View to toggle the Time Zones Window.  Time 
zones must total 24 hours and start and stop at midnight. 

User ID This must be a unique user ID equal to or less than 10 characters (No 
spaces, punctuation or special characters allowed.) This ID is used to log on 
to Perceptrak. 

Video Status 
bar 

Located directly under each camera in the Quad display; this is used to 
display textual information such as time, date, camera name, and number. 
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